BLE Dongle Setup

Introduction

This page will guide you through the process of getting your BLE dongle setup for use with the Bean SDK and CLI for Node.js. The reason a dongle is required for certain platforms is to work around problematic platform-specific BLE APIs (e.g. Windows).

The following platforms require a dongle:

  • Windows (all)
  • Linux (if no builtin BLE)
  • Raspberry Pi 1 & 2 (no builtin BLE)

The following platforms do not require a dongle:

  • OS X (all)
  • Linux (with builtin BLE)
  • Raspberry Pi 3

Here is a list of BLE dongles that we have tested with that work:

Dongle setup

First, download the Zadig tool.

Then, select Options > List All Devices.

Zadig 1

Find your BLE adapter in the device dropdown list and click "Replace Driver". Make sure you are replacing it with the WinUSB driver (even on Linux!).

Zadig 2

You should see the following dialog if successful.

Zadig 3

All done! Your dongle should be ready to use with the Bean SDK and CLI.

Driver Uninstall

If you wish to uninstall the WinUSB driver you can use Windows device manager.

Zadig 4